Ford-Rangers.com Ranger Forum HomeFord-Rangers.com Ranger Forum Home
Home Recent Topics New posts Search search Menu menu Not logged in - Login | Register

Ford-rangers.com is a discussion forum, a Ranger forum for people who have questions about fixing or modifying
their Ford Rangers or people who just admire their Ranger. Please join and enjoy sharing experiences!

coolant system       #: 465
 Moderated by: NoPower, Mike69, MaDMaXX
New Topic Reply
 Rate Topic 
 Posted: Tue Jan 9th, 2018 03:38 pm
PM Quote Reply
1st Post
stakreutermazda
Member
 

Joined: Sun Jan 7th, 2018
Location:  
Posts: 11
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 11
Replacing the coolant system on a 2000 Mazda b2500 2.5L.So far, new radiator, clean and test the sending unit and the sensor, replace the thermostat. flushed the heater core, got clean water but it didn't come out very hard or fast, but I didn't force it in so what goes in comes out? Replaced the heater control valve but need to find out which hoses go to which ports, don't want to put them on reversed. I'm going to check vacuum hose next, if it's no vacuum, how do I find it? I know where it ends but where does it start? Can I reroute it? Kind of hard if I can't find the beginning. Don't think I left anything out but I'm all ears,Thanks, and a special thanks to Jammin.

Back To Top PM Quote Reply

 Posted: Tue Jan 9th, 2018 11:27 pm
PM Quote Reply
2nd Post
JAMMAN

Owns A Torsen


Joined: Mon Sep 18th, 2017
Location: Grove City OhioUSA
Posts: 5751
Name: Jim
Occupation: 5 axis cnc programmer
Interests: RBV's
Status: 
Offline
Reputation: 
Reputation Points: 9335
I took pictures today of my 2000 that came with a 2.5. I'll upload them as soon as I can find a USB cord....



____________________
Truth sounds like hate for those who hate truth.

00 XLT 4WD RCSB 3.GO! Jalapeño
01 XLT 2WD RC Steppie 3.0 auto Silver
Back To Top PM Quote Reply

 Posted: Tue Jan 9th, 2018 11:38 pm
PM Quote Reply
3rd Post
JAMMAN

Owns A Torsen


Joined: Mon Sep 18th, 2017
Location: Grove City OhioUSA
Posts: 5751
Name: Jim
Occupation: 5 axis cnc programmer
Interests: RBV's
Status: 
Offline
Reputation: 
Reputation Points: 9335
Heres the pictures I got from the firewall. Does this look like yours?














____________________
Truth sounds like hate for those who hate truth.

00 XLT 4WD RCSB 3.GO! Jalapeño
01 XLT 2WD RC Steppie 3.0 auto Silver
Back To Top PM Quote Reply

 Posted: Thu Jan 11th, 2018 02:39 am
PM Quote Reply
4th Post
stakreutermazda
Member
 

Joined: Sun Jan 7th, 2018
Location:  
Posts: 11
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 11
Yep, thats it,except, Going by a dealer diagram yours is backwards.I'll need to find out how to send you a picture over this site. The port on the left should be on the right and pointed up to accept the left side hose to core, Then, I need to find out which feed hose goes to what will now be facing down. I have hose to thermostat on left and the hose from water pump T on right. Give me a school on using the picture sending stuff. Thanks

Back To Top PM Quote Reply

 Posted: Thu Jan 11th, 2018 02:48 am
PM Quote Reply
5th Post
stakreutermazda
Member
 

Joined: Sun Jan 7th, 2018
Location:  
Posts: 11
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 11
sorry, hose on right, not left

Back To Top PM Quote Reply

Current time is 06:44 am Top  

Ford-Rangers.com Ranger Forum > Tech Section > General Technical Questions > coolant system

Users viewing this topic



© 2007-2021 Chris -N- Jim
Page processed in 0.1803 seconds (13% database + 87% PHP). 49 queries executed.