Ford-Rangers.com Ranger Forum HomeFord-Rangers.com Ranger Forum Home
Home Recent Topics New posts Search search Menu menu Not logged in - Login | Register
Ford-Rangers.com Ranger Forum > Tech Section > General Technical Questions > Truck didn't start tonight...arg. Help

Ford-rangers.com is a discussion forum, a Ranger forum for people who have questions about fixing or modifying
their Ford Rangers or people who just admire their Ranger. Please join and enjoy sharing experiences!

Truck didn't start tonight...arg. Help       #: 444
 Moderated by: NoPower, Mike69, MaDMaXX Page:  First Page Previous Page  1  2  3   
New Topic Reply
 Rate Topic 
 Posted: Sat Jan 20th, 2018 03:48 pm
PM Quote Reply
51st Post
Mike69

Mustang Nut


Joined: Sun Oct 22nd, 2017
Location: Toms River  New JerseyUSA
Posts: 1500
Name: Mike
Occupation: Merchandising
Interests: Vintage Mustangs, RBV's, car shows, & woodworking
Status: 
Offline
Reputation: 
Reputation Points: 2695
JAMMAN wrote: Is that like POR15?

Looks like it is just about the same price isn't POR15 like the industry standard for frame restoration and preservation?

Jim if you were asking about the stuff I posted about, yes it is like POR-15.



____________________
08 Escape 4x4(spare)
00 Ranger Extd Cab 4x4 4.0 OHV, Auto(My DD)
99 Explorer Sport 4x4 4.0 SOHC, Auto( Wife's DD)
69 Mustang Coupe 5.0, 5 spd(Project & my future toy)
14 Kawasaki Vulcan (Wife's Toy)
Splitting time between southern NJ & Southern Virginia.
Back To Top PM Quote Reply

 Posted: Sat Jan 20th, 2018 06:15 pm
PM Quote Reply
52nd Post
NewShockerGuy
Member


Joined: Mon Oct 23rd, 2017
Location: Virginia USA
Posts: 144
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 309
Thanks to Jim in another thread I was able to "test" out the old pump I just puled out. Purple w/black wire is the 12v power, and the black is ground.

Took a 12v power supply to those wires and it was the faintest of noises. NOT that whine noise or loud pump running sound at all. Tested it again and made ZERO sound. I think it's safe to say that this pump is definitely dead.

Time to install the new one. Will report back.

-Nigel



____________________
__________
2001 XLT 2.3L


~NSG~
Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 03:02 am
PM Quote Reply
53rd Post
NewShockerGuy
Member


Joined: Mon Oct 23rd, 2017
Location: Virginia USA
Posts: 144
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 309
Installed the new pump and while I was there installed new fuel filter.  Turned the key to the on position, didn't hear anything.  Did it again and still didn't hear anything.  Said f it and cranked it.  Started right up!
Success!!
I went to test the old pump I removed and I could hear it running for about 5 seconds.  Then tried it again and nothing...Lol. Old pump was definitely done son!  I'm just glad it didn't stop working when i was at work because there would have been no way to get it out of the parking garage...Lol. Or left me stranded on the street.
I tried multiple times with new pump.  Started up every time.  I even waited a little to see if it would hesitate like it was before...nothing.
Feel so happy that it's running again..woot woot!  They must have changed something in the new pump because it's dead silent compared to the old one.
Thanks for all the help everyone!
-Nigel



____________________
__________
2001 XLT 2.3L


~NSG~
Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 06:30 am
PM Quote Reply
54th Post
MaDMaXX

Hails from the land of rust!


Joined: Sat Oct 21st, 2017
Location: Oregon USA
Posts: 1368
Name: 
Occupation: 
Interests: Motorsport/Firearms/IT
Status: 
Offline
Reputation: 
Reputation Points: 2163
That's weird how it's so quiet, but smooth i guess.



____________________
2002 - 3.0 - 4x2 - Edge

Upgrades/Maintenance log
Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 12:44 pm
PM Quote Reply
55th Post
JAMMAN

Owns A Torsen


Joined: Mon Sep 18th, 2017
Location: Grove City OhioUSA
Posts: 5691
Name: Jim
Occupation: Design and Innovation
Interests: RBV's, Computers
Status: 
Offline
Reputation: 
Reputation Points: 9200
A running ranger is the best kind! Glad you got it going :)



____________________
Truth sounds like hate for those who hate truth.
00 XLT 2WD RCSB 5.0 swap Gherkin (now a parts truck)
00 XLT 4WD XCSB 4.0 G2 (For Sale)
00 XLT 4WD RCSB 3.GO! Jalapeño (will keep till death)
99 XL 4WD RCSB 3.0 PJ (Plain Jane) For Sale
00 XLT 2WD RC Steppie 2.5 Dee Dee For Sale
01 XLT 2WD RC Steppie 3.0 auto SIlver

NOT ALL Amazon Green Metallic
Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 01:15 pm
PM Quote Reply
56th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2475
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3850
Great job, Nigel! This has been a tough one with all the cold weather getting in the way. I guess it's now on to the frame clean and coat.



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 Open 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 07:03 pm
PM Quote Reply
57th Post
Mike69

Mustang Nut


Joined: Sun Oct 22nd, 2017
Location: Toms River  New JerseyUSA
Posts: 1500
Name: Mike
Occupation: Merchandising
Interests: Vintage Mustangs, RBV's, car shows, & woodworking
Status: 
Offline
Reputation: 
Reputation Points: 2695
I just finished putting a new fuel pump in my Wife's 99 Explorer Sport. I used a Bosch pump & like Nigel's new pump when you turn on the key you can not hear it make any sound at all like the old one did (when it worked).



____________________
08 Escape 4x4(spare)
00 Ranger Extd Cab 4x4 4.0 OHV, Auto(My DD)
99 Explorer Sport 4x4 4.0 SOHC, Auto( Wife's DD)
69 Mustang Coupe 5.0, 5 spd(Project & my future toy)
14 Kawasaki Vulcan (Wife's Toy)
Splitting time between southern NJ & Southern Virginia.
Back To Top PM Quote Reply

 Posted: Sun Jan 21st, 2018 09:40 pm
PM Quote Reply
58th Post
NewShockerGuy
Member


Joined: Mon Oct 23rd, 2017
Location: Virginia USA
Posts: 144
Name: 
Occupation: 
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 309
Mike,

Makes me wonder if they changed something over the years..? Would make sense that after 17 years they are probably using a more efficient/quieter pump perhaps?

Good link for the filler tube! I just ordered that and the big hose. My smaller vent hose looked OK, so I am keeping that one as is. The larger fuel hose feels crumbly to me.

Seems like a quality part so while everything is off it's just good measure to do it I think.

-Nigel



____________________
__________
2001 XLT 2.3L


~NSG~
Back To Top PM Quote Reply

Current time is 08:00 pm Top Page:  First Page Previous Page  1  2  3     

Ford-Rangers.com Ranger Forum > Tech Section > General Technical Questions > Truck didn't start tonight...arg. Help

Users viewing this topic



© 2007-2020 Chris -N- Jim
Page processed in 0.2015 seconds (14% database + 86% PHP). 60 queries executed.